Google Translator

classic Classic list List threaded Threaded
2 messages Options
Feather45 Feather45
Reply | Threaded
Open this post in threaded view
|

Google Translator

Have just tried to download Google Translator for Firefox, but won't download on to my Galaxy Tab S because it says it's not compatible with my version of Firefox 38.0.5.

When will this addon be compatible with my version of Firefox?
nobzol nobzol
Reply | Threaded
Open this post in threaded view
|

Re: Google Translator

Hi, I am sorry, but I use 38.0.5 on my PC and it works fine. I don't know, but maybe your tablet (?) is not supported. I don't test the add-on on any mobile platforms.